Back to overview
Degraded
Degraded performance for some customers
Mar 18, 2026 at 6:45am UTC
Affected services
Email Tracking
Resolved
Mar 18, 2026 at 8:31am UTC
Our technical team has a applied a workaround at 08:39 CET to restore normal functionality. We are continuing to monitor the situation.
Affected services
Created
Mar 18, 2026 at 6:45am UTC
We have identified degraded performance affecting customers who use the CloudValid service for DNS configuration.
Affected services