Degraded Performance - Delayed Logs
Updated
Apr 23, 2026 at 12:17pm UTC
The "Accepted At" timestamps for older messages have been corrected. Some anomalies may still be visible - for example, not all delivery attempts for a message may be showing yet. These will appear as we continue to process the remaining corrections.
Affected services
Updated
Apr 23, 2026 at 12:09pm UTC
We have identified the root cause of the timestamp display issue. Some message logs are showing incorrect "Accepted At" dates, which may make emails appear to have failed when they were in fact accepted and processed at an earlier time. Email delivery itself has not been affected by this issue.
As of 14:14 today (5 minutes ago) we have deployed a fix for timestamps on all new messages. We are currently running a correction for existing affected messages and will update once this is complete.
Affected services
Updated
Apr 23, 2026 at 10:58am UTC
We are receiving reports that some customers are again experiencing issues with the display of timestamps in their logs. We are investigating and will provide an update shortly. Email delivery is not affected.
Affected services
Updated
Apr 23, 2026 at 8:39am UTC
We want to clarify that this incident did not affect email delivery. All emails were delivered normally throughout the incident. The issue was limited to the display of timestamps in our back-end. We are currently correcting the affected timestamps and expect this to be fully resolved shortly.
Affected services
Updated
Apr 22, 2026 at 11:22am UTC
New traffic is processing normally. We are continuing to investigate the impact on emails that were delayed during the incident and will provide a further update shortly.
Affected services
Created
Apr 22, 2026 at 10:05am UTC
Some customers have been experiencing degraded performance resulting in delayed email delivery. We are investigating the issue and will provide updates as we have more information.
Affected services