Back to overview
Degraded
Delivery issues to Microsoft
May 22, 2026 at 2:03pm UTC
Affected services
Email sending
Resolved
May 22, 2026 at 7:05pm UTC
The issue has been resolved.
Affected services
Created
May 22, 2026 at 2:03pm UTC
Some customers are currently experiencing delivery delays to Microsoft-hosted mailboxes (Hotmail, Outlook, Live). Microsoft has temporarily rate limited one of our sending IPs.
Emails are being queued and will be delivered once the rate limit is lifted. We are actively working on resolving this. No emails are lost.
Affected services