Back to overview
Downtime
Some services are currently unavailable
Jun 9, 2026 at 9:23am UTC
Affected services
dash.ahasend.com
EU (send.ahasend.com:587)
US (send-us.ahasend.com:587)
Email sending
API v2
API v1
Webhooks
Resolved
Jun 9, 2026 at 9:56am UTC
Corrective actions have been taken to prevent the problem from recurring.
Affected services
Updated
Jun 9, 2026 at 9:36am UTC
A misconfigured deployment job caused service outage. All services are now back to normal.
Affected services
Created
Jun 9, 2026 at 9:23am UTC
Our team is investigating reports about some services that are currently unavailable
Affected services