Delivery Delays to Microsoft Mailboxes (Outlook, Hotmail, Live)
Resolved
Jun 18, 2026 at 12:30pm UTC
We have applied mitigation measures on our end to work around the certificate issue on Microsoft's servers.
Delivery to Microsoft-hosted mailboxes should now be processing normally.
Delivery for affected emails that were queued during the incident will be retried automatically.
We will continue to monitor closely.
Affected services
Created
Jun 18, 2026 at 11:25am UTC
We are aware of delivery delays to Microsoft-hosted mailboxes (Outlook, Hotmail, Live). This is a global issue affecting many senders, not specific to AhaSend.
The cause is a certificate validation problem on Microsoft's mail servers. An intermediate certificate was recently removed from common CA bundles, but Microsoft's servers are still presenting it, which causes TLS certificate errors when delivering to their domains.
Affected emails are not lost. They are being queued and retried automatically, and will be delivered once the issue is resolved on Microsoft's end.
We are actively monitoring the situation and have applied mitigations where possible.
We will update this status as the situation develops.
Affected services