Delivery Delays - Partial Infrastructure Issue
Resolved
Jun 29, 2026 at 9:39pm UTC
All queues are back to normal with normal Delivery Times for new messages.
Affected services
Updated
Jun 29, 2026 at 9:29pm UTC
Update
We are seeing positive results from our mitigation efforts, alongside those of our network provider. Queues are now being drained and we are seeing improved delivery times.
We will continue to monitor closely and confirm once everything is fully back to normal.
Affected services
Updated
Jun 29, 2026 at 9:06pm UTC
We've applied mitigation for most affected paid customers.
Affected services
Updated
Jun 29, 2026 at 7:47pm UTC
One of our Network providers is experiencing a large-scale DDoS attack targeting portions of their network infrastructure.
"Our network engineering team is actively working to deploy additional permanent mitigation measures to fully address this attack and further strengthen the resilience of our infrastructure. Temporary mitigation is already in place, and we continue to monitor and adapt our defenses as the attack evolves."
Affected services
Created
Jun 29, 2026 at 7:04pm UTC
We are currently seeing delivery issues affecting part of our infrastructure. As a result, some outgoing email is being delayed.
Affected emails are not lost. They are being queued and will be delivered automatically once the issue is resolved. We are actively investigating and will provide an update shortly.
Affected services